How to solve Problems with Outlook Mobile Access

As written in my last post, I got more than strange errors after integrating PHP into IIS 6.0.

Here a list of errors I received for Outlook Mobile Access (OMA):

Unbekannter Fehler beim Verarbeiten der aktuellen Anforderung:
Meldung: Methode nicht gefunden: System.String System.DirectoryServices.DirectoryEntry.get_Password().
Quelle: Microsoft.Exchange.OMA.Preferencing
Stacktrace:
bei Microsoft.Exchange.OMA.Preferencing.AdUserObject.get_globalWirelessEnable()
bei Microsoft.Exchange.OMA.Preferencing.AdUserObject.get_UserIsWirelesslyEnabled()
bei Microsoft.Exchange.OMA.Preferencing.OmaUserInfo.get_UserIsWirelesslyEnabled()
bei Microsoft.Exchange.OMA.UserInterface.Global.Session_Start(Object sender, EventArgs e)

Meldung: Eine Ausnahme vom Typ Microsoft.Exchange.OMA.DataProviderInterface.ProviderException wurde ausgelöst.
Ereignismeldung:
Benutzermeldung: Systemfehler bei der Verarbeitung Ihrer Anforderung. Versuchen Sie es erneut. Wenden Sie sich an Ihren Administrator, wenn das Problem wiederholt auftritt.
Quelle: Microsoft.Exchange.OMA.UserInterface
Stacktrace:
bei Microsoft.Exchange.OMA.UserInterface.Global.Session_Start(Object sender, EventArgs e)
bei System.Web.SessionState.SessionStateModule.RaiseOnStart(EventArgs e)
bei System.Web.SessionState.SessionStateModule.CompleteAcquireState()
bei System.Web.SessionState.SessionStateModule.BeginAcquireState(Object source, EventArgs e, AsyncCallback cb, Object extraData)
bei System.Web.HttpApplication.AsyncEventExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
bei System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)
(source MSExchangeOMA, event ID 1503). Another error was event ID 1309, source ASP .NET 2.0x.

I can not locate the origin of this error but I solved it in the following way: First I regenerated OMA and OWA virtual directories as described in Microsofts KB.
Next I deleted the existing application pool in IIS manager and created a new one called ExchangeMobileApplicationPoo“.
I assigned “OMA” to ExchangeMobileApplicationPoo” and set the ASP.NET environment to version 1.1. OMA only works with ASP.NET 1.1. The funny thing is that our previous OMA configuration run under ASP.NET 2.0.x – whatever.

Leave a reply

Your email address will not be published.

You may use these HTML tags and attributes:

<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>