Von virtuellen Maschinen und komischen Fehlern

Meine Herren, was für eine stressige erste Woche. Auf der Arbeit ist viel passiert. Dienstag fand unser Team-Meeting statt und die schriftliche Ausbilder-Prüfung, Mittwoch das erste Meeting mit den Azubis, Donnerstag Projekt-Meeting und heute Vorbereitung auf die Ausbilder-Präsentation.

Die schriftliche Ausbilder-Prüfung lief nicht sonderlich gut, umso mehr überrascht war ich, dass ich trotzdem bestanden habe. Ich war mir eigentlich ziemlich sicher, dass ich durchgerauscht bin. Die schriftliche Ausarbeitung war hingegen ganz gut. Naja egal, hauptsache bestanden und schauen, was ich am nächsten Dienstag bei der Präsentation reißen kann.

Während der Woche hatte ich mehrere Baustellen zu betreuen. Unser SVN-Tool zum Auslesen von Repositories benötigte einige Refactorings und mit dem Update auf die Apache POI 3.0.2 Final bekam ich den Fehler “unable to construct record instance”. Ich bin offensichtlich nicht der einzige, der dieses Problem hat.

Neben diesem Problem kämpfte ich gestern mit der Installation des GWTDesigners für ein weiteres Projekt. Aus unerfindlichen Gründen wurde die falsche web.xml des GWT-Projekts herangezogen, so dass unser Globals-Servlet nicht beim Start des Tomcats geladen wurde und wir keinen Zugriff auf die Datenbank hatten. Nachdem ich dieses Problem löste, kompilierte mir das GWT nicht die richtigen Java-Dateien. Leider kann ich den Lösungsweg nicht mehr nachvollziehen.

Und zu guter letzt kämpfte ich mit der Migration unserer virtuellen Maschinen von Virtual Server 2005 nach VMWare Server. VMWare bietet zwar den VMWare Converter an, der funktioniert aber nicht so, wie er eigentlich sollte. Das Debug-Log bietet unzureichende Hilfe-Stellung. Unter anderem behauptet es, dass die virtuelle Festplatte der VS-VM-Instanz defekt sei, was völliger Blödsinn ist.
Mit der Benutzung des Virtual Machine Importers -die “Vorgängerversion” des Converters- konnte ich die VM zwar konvertieren , aber beim Hochfahren des System hagelte es Fehlermeldungen ohne Ende.
Windows Server 2003, das auf dem System installiert ist, konnte zuerst nicht die richtigen Treiber für den SCSI-Festplattenzugriff installieren und schließlich kam ich zu einem Henne-Ei-Problem: VS2005 benutzt einen anderen Netzwerktreiber als VMWare. Normalerweise sollte Windows nun erkennen, dass eine andere virtuelle NIC vorhanden ist und den alten Treiber automatisch deaktivieren und die neue NIC einrichten. Tat es aber nicht.
Ich hatte keinen Zugriff auf die Treiber und konnte die automatische Suche nach Treibern im Internet nicht durchführen, weil ich kein Netzerkzugriff habe. Das Einbinden einer manuell erzeugten ISO mit AMD-NIC-Treibern auf das virtuelle CD-ROM-Laufwerk funktionierte zwar, aber die Treiber an sich funktionierten trotzdem nicht.
Alles in allem war das sehr frustrierend. Christoph probierte heute die Live-Migration eines physikalischen Systems mit dem VMWare Converter aus. Ob alles geklappt hat, werde ich Montag erfahren.

Für das Wochenende steht heute Abend Kickern im Merz an, morgen wollten wir dann mal im Sausalitos vorbei schauen. Holger ist nämlich am Wochenende in Wolfsburg und da muss man ja mal was machen 😉

Soweit erst einmal

Leave a reply

Your email address will not be published.

You may use these HTML tags and attributes:

<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>